Service Disruption Notification
Incident Report for Crowdcast
Resolved
This incident has been resolved. Thank you for your patience and understanding during this challenging time.
Posted Jun 13, 2023 - 14:07 PDT
Monitoring
We are beginning to see a resolution to the issue. We are continuing to work towards full recovery.
Posted Jun 13, 2023 - 13:42 PDT
Identified
We regret to inform you that our site is currently experiencing technical difficulties preventing access or going live. This disruption is due to an ongoing outage in the Amazon Web Services (AWS) infrastructure, which we rely on as a service provider.

Our team is actively monitoring the situation and working diligently to restore normal operations as soon as possible. However, please note that the timeline for resolution is dependent on AWS resolving the underlying issues.

We apologize for any inconvenience this may cause and understand the impact it may have on your experience. Rest assured that we are committed to keeping you updated throughout the restoration process. Please refer to this status page for the latest updates on our progress.

Thank you for your patience and understanding during this challenging time. We appreciate your continued support and assure you that we are doing everything we can to address the issue swiftly.

If you have any urgent inquiries or need assistance, please reach out to our customer support team at support@crowdcast.io. We will provide further updates as new information becomes available.
Posted Jun 13, 2023 - 12:33 PDT
This incident affected: Browser App, API Server, iOS App, and Recording & Streaming Servers - In Browser Sessions.